「XREAの灯」掲示板
 XREAユーザー,Coreserverユーザー,Value-Domainユーザーの掲示板です.
 初めての方もネチケットを守って,お気軽にご参加下さい(^^)/
 リンクは当面,http://xrea.users-net.com/へお願いします.
16 / 17 ページ    ←次へ | 前へ→

★CGI設置の問題解決!!そのために…
 tamaya  - 12/10/30(火) 2:18 -
出典:
http://sb.xrea.com/showthread.php?t=1824

■タイトルを熟考しよう
このフォーラムを閲覧しているひとは、
SOS信号をさがして閲覧しているわけではありませんので
「質問です」「困っています」「できません」「助けて」という
スレッドタイトルでは、投稿内容を読まない限り
何について困っているのかがさっぱりわかりません。

■あとで検索する誰かのために
スプリクト名をタイトルや本文に忘れず入れませう。
そして一度解決した後でも、そのスクリプトの設置などで
気付いたことなど新しい情報を追加すると
「ただ質問しただけのスレッド」は「誰かの疑問を解消する
ヒント満載のスレッド」として息を吹き返します。

■「とにかくできません」てどうなの
パーミッションは間違ってないし
とりあえずXフォルダにも入れてみたから広告のせいじゃない
なのにどうして!どうして!!…とあわてるきもちはよくわかりますが
「どうにもならない焦りっぷり」を表現してもラチがあきません。
質問投稿では、心情を強調する必要はありません。
静かな静かなキモチで質問文を推敲してみましょう。

●やってみることリスト
・20分ほど設置のことをあたまから追い出してお茶タイム
・http://www.xrea.com/jp/spec.shtmXREAの仕様を再度確認
・配布サイトにある設置マニュアルを読み直す
・スクリプトに添付されていたRead meやマニュアルを読み直す
・余計な改造を一切しないでためしにXディレクトリにあぷろーどしてみる
・XREA推奨のパーミッションと配布元推奨のパーミッションをそれぞれ試してみる
・あぷろーど後のお茶たいむ。(反映が遅いのかもしれません)
・XREAサポート掲示板のログを検索
(検索語を*ではさんで検索。例:「*検索語*」)
・ここに目を通してみる(なにかヒントがあるかもしれません。)
*障害・メンテナンスカテゴリー
*ハズかッチ〜♪ くて、今更こんなことは聞けません!! ?(;´Д`)
*Cgiのみの利用について *絶対パス
*リンク先※CGI設置トラブルかたっぱしから
*CGIの広告について *CGIの数

それから大事なことです。
アカウントは取り立てほやほやではないですか?
取り立てのアカウントははんぶん寝ているようなものだと考えて
新規のアカウントは2〜3日ゆっくり寝かせてあげましょう。

そして質問文を送信する前に
あなたが質問を投稿しようとしているフォーラムの
スレッド一覧に並んでいるタイトルを眺めてみてください。
どんな題名が並んでいますか?
参考にできそうなスレッドはありましたか?

「参考にならなかった」と思ったのであれば
自分のあとに同じスクリプトでつまづく人が
参考にできる質問スレッドに育てる、というきもちをわすれずに
胸をはって投稿しましょう。
質問するときに忘れてはいけないこと色々

■解決したら
「うまくできなかった原因は何だったのか」
うまくできなかった原因は何だったのか依然として不明な場合は
「うまくできなかった原因の仮説」
「参考になった意見、方法、サイトなど」

あなたの立てた質問スレッドを、
きれいにまとめてしめくくることをわすれずに。お礼のことばもあるともあべたー(愛


そもそも鯖が落ちてるとかってことはないかしら
■ご利用の鯖の障害情報の確認はこちら
サーバー障害連絡


■ゲームCGI設置に関するアレコレ
※XREAではスプリクトの名指し禁止こそはしていませんが、
鯖に過剰な負担がかかってしまうものが多く、さらに
他ユーザーに多大な迷惑をかけ、結果として
アカウント凍結・削除されることも予想されます。
以下に紹介するスレッドには設置のヒントもありますが、
ほかの共有鯖で禁止されているゲームCGIは
XREAでもやっぱかなり無理があるものだとおもいます。
自分たちの使っている鯖におおきな負荷をかけるようなCGIの
設置方法を質問されるほかのユーザーのきもちを想像し
設置について考えてみてもらえたらたぶんとてもうれちい。
引用なし

パスワード


1,099 hits
・ツリー全体表示

不要なメールの削除方法について(2005)
 marry  - 12/10/30(火) 0:49 -
 2005年9月にXREAのwebmasterさんがXREA本家サポート掲示板に
書き込んだ内容です.Xrea/Coreserverのメールの仕組みを
理解するのに役立ちますので,引用します:
引用元:
http://sb.xrea.com/showthread.php?t=10001

不要なメールが大量に来ており、全て、もしくは、大量に削除したいという場合の方法を紹介いたします。ウェブメールや、ツール経由では時間が掛かる場合に有効です。

○事前に知っていただきたいこと
「sample」というユーザー名のabc@example.com というメールアドレスを例として解説します。
abc@example.comの場合に、メールが届けられるのは、
/virtual/sample/Maildir/example.com/abc/Maildir/
の中になります。この中に、「new」「cur」というディレクトリがありますが、未読の新着メールは「new」に届けられます。
IMAPやウェブメールからアクセスされますと、それらのメールは「cur」に移動します。


○削除方法
1)ドメインメールの設定画面から「メールボックスを初期化する」にチェックを入れ、設定ボタンを押します。この作業をされない場合、ユーザー権限の問題で削除できない場合があります。
2)30分程度お待ちいただき、SSH、CGI、FTP、ファイルマネージャなどで下記ディレクトリ内のファイルを削除します。
/virtual/sample/Maildir/example.com/abc/Maildir/cur

大量のメールがある場合、処理に時間が掛かります。SSHか、CGIを使った場合、比較的早く削除可能です。

・SSHの場合、ログインしていただいた後、
 cd /virtual/sample/Maildir/example.com/abc/Maildir/cur
find . -type f -exec grep "メールに含まれる文字列" {} \; -print -exec rm -f {} \;
とうってください。特定の文字列を全文検索し、削除します。

・CGIの場合、下記内容で「rm_mail.cgi」などとしファイルをアップロードし、実行してください。
Code:
#!/bin/sh
echo "Content-Type: text/html"
echo
cd /virtual/sample/Maildir/example.com/abc/Maildir/cur
find . -type f -exec grep "メールに含まれる文字列" {} \; -print -exec rm -f {} \;

○その他
・一切内容を読んでいない新着メールを削除する場合は、curをnewに変えて、同様の処理を行なってください。
・文字列を検索せず、全てのメールを削除する場合は、
find . -type f -exec grep "メールに含まれる文字列" {} \; -print -exec rm -f {} \;

find . -type f -exec rm -f {} \;
に変えてください。

・応用としまして、
cd /virtual/sample/Maildir/example.com/abc/Maildir/cur
find . -type f -exec grep "***VIRUS***" {} \; -print -exec mv -f {} /virtual/sample/MyMailBox/virus/\;

などのコマンドで特定の文字列の入ったメールを振り分け、移動させることも出来ます。CRONTABとの連携も可能です。

以上
引用なし

パスワード


2,561 hits
・ツリー全体表示

引っ越し先サーバーを選択するヒント
 marry  - 12/10/30(火) 0:40 -
 引っ越し先を検討する場合に役立つtipsが紹介されています:
CORESERVER 負荷率 サーバー移動(サーバー間コピー)[XREA]
http://ecsite.jugem.jp/?eid=160
引用なし

パスワード


1,738 hits
・ツリー全体表示

サーバー負荷観測所
 marry  - 12/10/30(火) 0:22 -
 こちらも同様な負荷観測所です.
http://server.x24hr.com/

 VALUE DOMAIN系列(xrea.com, coreserver.jp, coreblog.jp)の混雑値28日分を、一覧版では日別毎の平均を、詳細版では(1時間/1日/7日)の平均値や最大・最小値などを閲覧できます。
 サーバー移行/引越しや新規登録時の評判と実情の見極めから、障害関連や状態チェック等の評価/比較の判断材料等々…大いに役立ちます.

 貴重な観測データのご提供に感謝申し上げます.
引用なし

パスワード


2,162 hits
・ツリー全体表示

XREA CORESERVER 負荷観測 「障害情報ページ混雑度...
 marry  - 12/10/30(火) 0:19 -
 いわゆる「負荷観測所」です.私の一番のオススメです:
http://websrvtool.appspot.com/mainte_xrea.html

 XreaやCoresereverは共用サーバーです.だいたい数百のウェブサイトが1台のサーバーに同居しているのが,激安レンタルサーバーです.
 同居人にヘビー・ユーザーがいらっしゃると,そのサーバーの負荷が高まって反応が鈍くなるのは当然です.
 自分が借りているサーバーが我慢できないぐらい遅くなってしまったとき,あるいは他のサーバーより異様に遅いとき,サーバーの「お引っ越し」を考えます.

 そんなとき「引っ越し先」を探すのに必須なのが,こうした「負荷観測所」だと思います.「負荷観測所」の運営者のかたには頭が下がる思いです.感謝申し上げます.
 このサイトは過去2週間にわたる各サーバーの混雑度が数値と色分けで表示されていて一目瞭然です.(数値と色分けを併用したのは,good ideaだと思います.)
引用なし

パスワード


1,937 hits
・ツリー全体表示

役立つウェブサイトのリンク集
 marry  - 12/10/30(火) 0:10 -
 いずれホームページにまとめようと思いますが,取り急ぎ
役立つリンクをここにまとめてみました.
引用なし

パスワード


3,691 hits
・ツリー全体表示

改修されたようです
 marry  - 12/10/29(月) 5:19 -
 RapidSSLの中間証明書も使えるよう改修が行われたようです.

Value-domainさんの公式発表:
http://mainte.value-domain.com/event...erverAll&no=12

ユーザーさんの検証:
http://www.javable.jp/blog/169.html
引用なし

パスワード


1,586 hits
・ツリー全体表示

RapidSSLの仕様変更について
 marry  - 12/10/29(月) 5:18 -
 下記に情報がありました:
http://www.sslbox.jp/support/man/int...p#rapid_modify
引用なし

パスワード


1,432 hits
・ツリー全体表示

お疲れ様です
 marry  - 12/10/29(月) 5:17 -
thithiさん、ご報告ありがとうございます。参考になります。

>自分で取得したRapidSSLはGeoTrustにキャンセルを出し、SSLが必要なサイトを他の
>レンタルサーバで、SSLが不要なサイトは、coreserverの契約が終わり次第、xrea+
>で運用することになりました。
 う〜ん、そうでしたか。

>昔は、低コストで独自SSLを導入するにはcoreserverしか選択肢が実質なかったけど、今、
>他のレンタルサーバもcoreserverと同じくらいのコストになってたんですね。知りませんでした。
 xreaさんの対応がなければ、私も引っ越し先を検討するか、中間証明書が使える業者へ
乗り換えるしかないかも…。(-.-)
引用なし

パスワード


1,588 hits
・ツリー全体表示

諦めました。
 thithi  - 12/10/29(月) 5:16 -
結局、coreserverでの低コストでのSSL利用は断念。

自分で取得したRapidSSLはGeoTrustにキャンセルを出し、SSLが必要なサイトを他のレンタルサーバで、SSLが不要なサイトは、coreserverの契約が終わり次第、xrea+で運用することになりました。

昔は、低コストで独自SSLを導入するにはcoreserverしか選択肢が実質なかったけど、今、他のレンタルサーバもcoreserverと同じくらいのコストになってたんですね。知りませんでした。

一応、引越し先でのSSLチェックも無事終わったので報告までに。
Last edited by thithi : 2011/01/24 at 10:24 PM.
引用なし

パスワード


1,444 hits
・ツリー全体表示

marryさんへ
 thithi  - 12/10/29(月) 5:15 -
marryさんへ
>FireFox(v.3.6.13)ではエラー表示がでません
私のFireFoxは、3.6.10で、エラー表示が出ました。試しに別のPCにあった3.6.12でアクセスしたらエラーが出ませんでした。どうやらfirefoxでもバージョンによってエラーが出るか出ないか決まるようです。

なので2010/12/10以前のものでエラー表示になって中間証明書をインストールしたら直ったというサイト情報と整合するとmarryさんのRapidSSLでもエラー表示になっている人がいる可能性があります。

GeoTrust社、Comodo社の安いSSLがCoreserverで使えないとなると、引っ越したくないけど引越しを真剣に検討に入れないといけなくなってきました。
引用なし

パスワード


1,056 hits
・ツリー全体表示

事後報告(2011)
 thithi  - 12/10/29(月) 5:14 -
サポートに問い合わせたので一応報告致します。
回答された内容を要約すると、うちの仕様以外のことはできない、自分たちで解決してくれとのこと。
ま、想像した通りの対応でした。
なので今後、新規でRapidSSLを取得される方、又は昔取得したRapidSSLでfirefoxで不正なセキュリティ証明書を使用しています。と表示されるようになったら、coreserverではRapidSSLは事実上使用できないということで行動してください。

見事に犠牲者事例第一号になりました。みなさん同じミスをしないように、回避行動の参考にしてください。

それと誰か、安いSSLで最近coreserver設置に成功したよ、いう方がいたら、ぜひそのSSLの名前を教えてください。お願いします。
Last edited by thithi : 2011/01/21 at 01:36 PM.
Reply With Quote
引用なし

パスワード


1,043 hits
・ツリー全体表示

Re:追記:中間証明書が認証できません。(2011)
 thithi  - 12/10/29(月) 5:13 -
返信ありがとうございます。
Quote:
Originally Posted by marry View Post
thithiさん,はじめまして.私もCoreserverでRapidSSLを使っているので,書き込みを拝見して,不安になっています.
 私の証明書はまだ有効期間中のためか,FireFox(v.3.6.13)ではエラー表示がでません.

 2010年1月10日以降に新たに認証しようとすると,中間証明書が認証できずにエラーになるのでしょうね.

 まずはxreaのサポートへ連絡されてみてはいかがでしょうか?
 早期に解決することを祈念しております.
以前、取得したRapidSSLで試してなかったので、知りませんでした。そうすると新しいRapidSSLに限って発生する症状のようですね。
どうなるかわかりませんが、今日サポートに一応投げかけたいと思います。
もしダメだったら、中間証明書が不要なSSLを買わないとだめかも・・・。
引用なし

パスワード


1,312 hits
・ツリー全体表示

Re:追記:中間証明書が認証できません。(2011)
 marry  - 12/10/29(月) 5:11 -
thithiさん,はじめまして.私もCoreserverでRapidSSLを使っているので,書き込みを拝見して,不安になっています.
 私の証明書はまだ有効期間中のためか,FireFox(v.3.6.13)ではエラー表示がでません.

 2010年1月10日以降に新たに認証しようとすると,中間証明書が認証できずにエラーになるのでしょうね.

 まずはxreaのサポートへ連絡されてみてはいかがでしょうか?
 早期に解決することを祈念しております.
引用なし

パスワード


1,158 hits
・ツリー全体表示

追記:中間証明書が認証できません。(2011)
 thithi  - 12/10/29(月) 5:11 -
coreserverの内部システムがどういう仕組みになっているかわかりません。以下の参照サイトのように中間CA証明書のインストールエラーは何らかの設定を変えて、Apacheサーバを再起動する必要があるようです。
やはりcoreserver側が動いてくれないとエラー原因は解決しないような気がします。システムエラーでも共有サーバだからこういう場合って対応してくれないのか?
Quote:
http://blog.longkey1.net/archives/73
引用なし

パスワード


1,059 hits
・ツリー全体表示

追記:中間証明書が認証できません。(2011)
 thithi  - 12/10/29(月) 5:10 -
実は、2010/10/9にも同じようにRapidSSLを購入しちゃんとcoreserverで設定したことがあります。

そのときRapidSSLは、Web Server CERTIFICATEやINTERMEDIATE CAといった区分はなく、以下のメール文末を送ってきただけだったので、中間証明書(任意)を空欄にして設定していました。

Quote:
Your RapidSSL certificate:

-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----
今回は、2010/12/10からRapidSSLの仕様がかわったらしく、2011/1/15に購入した今回、Web Server CERTIFICATEやINTERMEDIATE CAの二つのCERTIFICATEをメールで送付してきました。

今現在、実はもう考えられるだけのパターンはやりつくして万策尽きており、以下のcoreserverのメッセージから抜け出せません。
Quote:
中間証明書が認証できません。入力内容をお確かめください。
そこでなんですが、まだcoreserverの方が、RapidSSLの仕様が変化したことに気づいていなくて対応できていない可能性はないのでしょうか。どうしても思考回路がそこに行き着いてしまいます。
引用なし

パスワード


1,053 hits
・ツリー全体表示

中間証明書が認証できません。(2011)
 thithi  - 12/10/29(月) 5:09 -
2011/1/15にRapidSSLを購入し、
発行された証明書(必須)を埋め、発行された中間証明書(任意)を空欄にしてCERT・証明書インストールボタンを押しhttps://自サイトに、firefoxでアクセスしたら
Quote:
hogehoge.com(自サイトURL) は不正なセキュリティ証明書を使用しています。

発行者の証明書が不明であるためこの証明書は信頼されません。

(エラーコード: sec_error_unknown_issuer)
と表示されました。
グーグルで調べたら2010/12/10まではRapidSSLは中間証明書が不要だったみたいでしたが、これからは必要になるからfirefoxでsec_error_unknown_issuerが出たら、中間証明書をインストールしたら直るとのこと。
Quote:
参考サイト
http://www.ict-solutions.jp/
対処法は、
RapidSSLを使う場合は、中間証明書のインストールが必要みたい。

なので、再度、発行された証明書(必須)を埋め、発行された中間証明書(任意)を埋め、CERT・証明書インストールボタンを押したら、今度は、coreserverの管理画面で以下のような注意をうけ進めません。

Quote:
中間証明書が認証できません。入力内容をお確かめください。
ごくごく最近こんなトラブルになって解決した人いますか?

追記:

発行された証明書(必須)には、RapidSSLからメールで送られてきたWeb Server CERTIFICATEの-----BEGIN CERTIFICATE----- から -----END CERTIFICATE----- まで
発行された中間証明書(任意)には、INTERMEDIATE CAの-----BEGIN CERTIFICATE----- から -----END CERTIFICATE----- まで
それぞれの入力欄に入れています。

以下RapidSSLから送られてきたメールの文末部分
Quote:
Web Server CERTIFICATE
-----------------

-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----


INTERMEDIATE CA:
---------------------------------------

-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----
Last edited by thithi : 2011/01/15 at 12:59 PM.
引用なし

パスワード


1,324 hits
・ツリー全体表示

中間証明書を使ったRapidSSLの更新方法(2011)
 marry  - 12/10/29(月) 4:57 -
 先の書き込みのように,Rapid SSLの中間証明書が認証できない問題はvalue-domainさんによって解決されているようです.
 自分のRapid SSLが,そろそろ期限なので更新してみたら,あっけなく完了しましたので,ご報告いたします.

(1)Coreserverのサーバー管理画面にログインする.

(2)SSL設定→証明書設定をクリックし,プライベートキーを生成するための情報とパスワードを入力してから,生成キーをクリックする.
 このとき現用のパスワードとは異なる,新たなパスワードにすることをオススメします.さもないと問題が起きたときの原因の切り分けが難しくなります.

(3)生成されたプライベートキーとCSRを前後の'---'とともに,それぞれ別のテキストファイルに保存します.
 プライベートキーは後ほど証明書のインストール時に使います.
 CSRはSSL再販業者へ送付するときに使います.

(4)SSL再販業者のサイトへ行って,RenewalとかRenewと書いてあるリンクをクリックします.

(5)SSL証明書の発行に必要な情報の入力を求められます.
 企業名とか,担当者名とか,所在地とか,メールアドレスなどなどです.
 私は海外の再販業者を利用したので,全部英語で入力しました.
 海外の再販業者が売るRapid SSLの再廉価版は1年間でUS$20未満とお得感があります.(^^)
 早めに更新すると,SSL有効期限延長ボーナスももらえます.

(6)いくつかの画面入力があって,最後に内容を確認する画面になりますから,よく確認してください.
 間違いなければ次の画面へ,修正するなら前の画面へ戻って修正します.
 たいていはe-mailによる有効化(validation)確認があります.再販業者によっては英語の音声による電話確認を併用していることがありますが,めんどうなのでe-mailだけで認証してくれる再販業者を選びます.
 validationメールは,サーバー管理者のメールアドレスとか,「webmaster@あなたの独自ドメイン」などのいずれかへ送るよう選択できます.

(7)引き続き支払い画面になりますので,決済します.
 私が利用したのは海外の再販事業者で,あまり知られていない業者なので,実態は不明です.ですから,いきなりクレジットカードで決済するのは不安でした.(クレジットカード情報が漏れる可能性は大いにあります^^
 Paypalによる代行決済が可能なら,Paypalを選ぶのが賢いと思います.ご存じのようにPaypalが介在するので,クレジットカード情報が再販事業者へ漏洩するリスクが小さいです.

(8)決済処理をしている間に,もうvalidationメールが届きました.
 認証用のURLが記載されているので,それをクリックして遷移する画面で承認ボタンをクリックすれば認証完了です.

(9)さきほどPaypalで決済したので,遅くとも数時間以内には証明書が届くはずです…と思っていたら,ものの10分ほどで証明書がe-mailが届きました.
 う〜む,今回は早い!
 (前回の更新では証明書メールを数時間待たされました.)

(10)証明書メールには下記がテキストで記載されています.
 (a)証明書(Certificate)
 (b)中間証明書(CA)

(11)Coreserverのサーバー管理画面にログインする.

(12)SSL設定→証明書設定をクリックし,上記(3)で保存したプライベートキーをコピーして,プライベートキー欄へペーストします.
 すでに画面に表示されているプライベートキーが手元の控えと同一内容なら,あらためてペーストする必要はありません.

(13)上記(12)と同じ画面に証明書の欄があるので,Geotrustから送られてきたRapid SSLの証明書をペーストします.
 中間証明書も同様にペーストし,SSL設定ボタンをクリックします.
 「SSL設定が更新されました」と表示されたらOKです.

(14)SSL証明書の更新内容が反映されるには,数時間かかるかと思っていたら,
なんと10分ほどで反映されていました.
 は,早い!(^^)
 https:で始まるページをブラウザで表示し,SSL証明書の内容を確認すると,
前回まではEquifax社名義だったのが,GeoTrust社名義に変わりました.
 有効期限もボーナス付きで更新されていて満足でした(^^)v

 今回はCoreserverの管理画面でSSL更新作業を始めてから30分あまりで証明書の更新と反映が済みました.

以上です.GMOインターネット傘下でも大丈夫な気がします.
やっぱりvalue-domainの自由度が高くて廉価なサービスは他社に類がなく,最高ですね! \(^o^)/
Last edited by marry : 2011/10/16 at 02:26 PM.
引用なし

パスワード


1,191 hits
・ツリー全体表示

Re:独自IPでアクセスできるのに独自ドメインでアク...
 marry  - 12/10/29(月) 4:53 -
saymanさん、こんにちわ。

 亀レスにつき、すでに解決ずみでしょうけれど…。(^^;;

>これだと独自IPでアクセスした場合みれるのですが
>ドメインでアクセスすると見れません。
 IPアドレスでアクセスできるのに、ドメイン名でアクセスできないのは、
DNSの設定が間違っているせいでしょう。

>sub1とかにドメインを設定すると
>ドメインでアクセスしたときに見れます。
 ならばDNSの設定は、すでになさっているようですね。

となると、最初の「ドメインでアクセスすると見れません。」との症状は、
ブラウザキャッシュが読み込まれているせいではないでしょうか?
(IEならCtrl-F5で強制読み込みできます。)


#ドメインは.comのようなeNom管理のものですか?それとも.jpでしょうか?
引用なし

パスワード


1,108 hits
・ツリー全体表示

独自IPでアクセスできるのに独自ドメインでアクセ...
 sayman  - 12/10/29(月) 4:52 -
よろしくお願いします

ドメインウェブの設定で
独自IPの箇所に
www.ドメイン
を入力して

DNSの設定では
a * 独自IP
a mail もともとのIP
mx mail.ドメイン. 10 @

としています。

これだと独自IPでアクセスした場合みれるのですが
ドメインでアクセスすると見れません。

ちなみにドメインウェブの設定で
sub1とかにドメインを設定すると
ドメインでアクセスしたときに見れます。

なにかまちがっているのでしょうか?

よろしくお願いします。
引用なし

パスワード


999 hits
・ツリー全体表示

16 / 17 ページ    ←次へ | 前へ→
 30,711
ページ:  ┃  記事番号:  

C-BOARD Moyuku v1.03b5